SSO Certificate Mismatch on UWS
Incident Report for Aula Education
Postmortem

The Single Sign-On (SSO) certificate for UWS was updated by UWS on Monday morning. This stopped the Aula integration with SSO from working because Aula requires an updated SAML configuration for the new certificate.

Once Aula had been notified of the issue, we temporarily disabled SSO for UWS so that end-users could sign in using magic links instead. Once we recieved the updated SAML configuration file we were able to re-enable SSO, and verify that the integration was working again.

The issue only affected new sign-in attempts. Users who were already signed in to Aula were unaffected. Based on reports recieved from Aula - at least 19 end-users were affected.

Posted Dec 03, 2021 - 15:42 UTC

Resolved
This incident has now been resolved. Apologies for any inconvenience caused.
Posted Nov 29, 2021 - 13:33 UTC
Monitoring
SSO has been re-enabled and confirmed to be working on our end.
Posted Nov 29, 2021 - 11:47 UTC
Update
We have received the updated metadata file and updated it within Aula. We are in the process of re-enabling SSO for UWS.
Posted Nov 29, 2021 - 11:41 UTC
Update
We have requested an updated metadata file from UWS. In the meantime we have disabled SSO for UWS which means users should be able to login using magic links.
Posted Nov 29, 2021 - 11:21 UTC
Identified
The SSO certificate for UWS has been updated and is therefore out-of-sync with the metadata held by Aula. This will cause SSO login attempts to fail until an updated metadata file is provided by UWS.
Posted Nov 29, 2021 - 11:19 UTC
This incident affected: Aula Application (3rd Party integrations).